PDX power outage
Incident Report for Opus Interactive
Resolved
The outage is resolved.
Posted Jul 23, 2017 - 18:28 PDT
Investigating
Team is engaged. Tata and Opus working on the issue.
Posted Jul 23, 2017 - 17:33 PDT